Author Topic: PPM608 powered mixer is DAY-idd.  (Read 2092 times)

Peegoo

  • Initiate
  • *
  • Location:
  • Posts: 1
PPM608 powered mixer is DAY-idd.
« on: April 09, 2013, 02:37:46 AM »
I've had this for a few years. When it works, it works great. About a year ago, it acted up (wouldn't power on), until I flipped the speaker selection switch on the rear panel up and down a few times. And all was good.

Now, it won't power up (no "power on" light on the front panel). There was no telltale POP, no smoke, nothing. It's as if it's plugged into a dead outlet.  The power cord is good. I knew the switch and main fuse were still good, because when I flipped on the power switch, the lights in the room dimmed slightly as the caps in the amp drew power.  The dual cooling fans are thermostatically controlled, so they don't kick on with power-up anyway.

I cracked the case open and tested the power cord, switch, and main fuse. All are good.  I have a good ground to the chassis.  I'm getting proper voltages off the test points on the power supply section of the PC board; it's conveniently labeled with proper voltages.  I'm getting the proper lower operating voltages for the front end (channel strips, effects section, master volumes, and patch points) through the ribbon cable.

I checked all the ribbon cables and they're all good.

I inspected the board and components and there are no cooked resistors, no popped caps, no fried-bacon traces...everything looks pristine, other than a little fine dust from the airflow.

I'm at the limits of my abilities because I can troubleshoot tube amps, but not solid state stuff.

I went online to see if this power thing is an issue, and apparently it is. The PPM-series powered mixers appear to be less than reliable. Lovely.

Any advice is greatly appreciated.  I thought I could troubleshoot this, but I may have to take it in for service...or toss it into the bay.

Greg C.

  • Forty-Two
  • Knight
  • ****
  • Location: N. CA.
  • Posts: 300
    • Cameron Pro Audio
Re: PPM608 powered mixer is DAY-idd.
« Reply #1 on: April 16, 2013, 05:47:54 PM »
The newer class D PPM mixers are garbage. The older PPM series was actually pretty decent. Sorry you got roped in. I'd see what it costs to fix it (if your repair center can even get parts out of Mackie (they don't stock much) and then unload it if it's repairable for a reasonable fee. Otherwise it's off to the ewaste facility.
Procrastinators of the World, Contemplate Uniting!

ferrographlover

  • Initiate
  • *
  • Location:
  • Posts: 1
Re: PPM608 powered mixer is DAY-idd.
« Reply #2 on: November 03, 2018, 11:54:35 AM »
The problem is almost certainly in the switch mode power supply, but may be caused by a short in an attached item causing the protection cicuit to cut the power.
Try disconnecting everything from the power supply and then add them back one at a time
I suggest you try with just one of the fans reconnected first but allow a few seconds after turning on for it to 'kick in'.
BE CAREFUL - YOU CAN RECEIVE A FATAL SHOCK FROM THE POWER SUPPLY. IF YOU DONT KNOW WHAT YOU ARE DOING LEAVE IT TO THE PROFESSIONALS.

By the way, I would be grateful if you could let me know the 'official' test point values as they are not printed on my PCB or in any published data sheets that I have found so far.

Cheers and good luck!

ferro.